using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"function (.+)\(.*\)\s*\{";
string substitution = @"$& console.log(""$1()"");";
string input = @" function example()
{
}
function example2()
{
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}