$re = '/function (.+)\(.*\)\s*\{/m';
$str = ' function example()
{
}
function example2()
{
}';
$subst = "$& console.log(\"$1()\");";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;