using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0?[1-9]|1[012]):([0-5][0-9])[ap]m$";
string input = @"09:00pm
09:00am
08:55pm
08:54am
10:00pm
1:00pm";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}