use strict;
my $str = '09:00pm
09:00am
08:55pm
08:54am
10:00pm
1:00pm';
my $regex = qr/^(0?[1-9]|1[012]):([0-5][0-9])[ap]m$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}