$re = '/^(0?[1-9]|1[012]):([0-5][0-9])[ap]m$/m';
$str = '09:00pm
09:00am
08:55pm
08:54am
10:00pm
1:00pm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);