package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0?[1-9]|1[012]):([0-5][0-9])[ap]m$`)
var str = `09:00pm
09:00am
08:55pm
08:54am
10:00pm
1:00pm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}