import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0?[1-9]|1[012]):([0-5][0-9])[ap]m$";
final String string = "09:00pm\n"
+ "09:00am\n"
+ "08:55pm\n"
+ "08:54am\n"
+ "10:00pm\n"
+ "1:00pm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}