import re
regex = re.compile(r"^(0?[1-9]|1[012]):([0-5][0-9])[ap]m$", flags=re.MULTILINE)
test_str = ("09:00pm\n"
"09:00am\n"
"08:55pm\n"
"08:54am\n"
"10:00pm\n"
"1:00pm")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")