const regex = /^(0?[1-9]|1[012]):([0-5][0-9])[ap]m$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0?[1-9]|1[012]):([0-5][0-9])[ap]m$', 'gm')
const str = `09:00pm
09:00am
08:55pm
08:54am
10:00pm
1:00pm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}