const regex = /([\x{0041}-\x{005A}]{2,})/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\x{0041}-\\x{005A}]{2,})', 'gu')
const str = `SONYA
We Want to only replace SONYA and not S O N Y A.
`;
const subst = `\L$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);