$re = '/([\x{0041}-\x{005A}]{2,})/u';
$str = 'SONYA
We Want to only replace SONYA and not S O N Y A.
';
$subst = "\L$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;