re = /([\x{0041}-\x{005A}]{2,})/
str = 'SONYA
We Want to only replace SONYA and not S O N Y A.
'
subst = '\\L$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result