import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"([\x{0041}-\x{005A}]{2,})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
SONYA
We Want to only replace SONYA and not S O N Y A.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\L$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)