using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!\.bin\.js$).)+\.js$";
string input = @"I want to match the following:
file1.js
file2.src.js
file3.bin.src.js
But not:
file1.bin.js
file2.src.bin.js";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}