import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!\\.bin\\.js$).)+\\.js$";
final String string = "I want to match the following:\n\n"
+ "file1.js\n"
+ "file2.src.js\n"
+ "file3.bin.src.js\n\n"
+ "But not:\n\n"
+ "file1.bin.js\n"
+ "file2.src.bin.js";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}