re = /^(?:(?!\.bin\.js$).)+\.js$/m
str = 'I want to match the following:
file1.js
file2.src.js
file3.bin.src.js
But not:
file1.bin.js
file2.src.bin.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end