import re
regex = re.compile(r"^(?:(?!\.bin\.js$).)+\.js$", flags=re.MULTILINE)
test_str = ("I want to match the following:\n\n"
"file1.js\n"
"file2.src.js\n"
"file3.bin.src.js\n\n"
"But not:\n\n"
"file1.bin.js\n"
"file2.src.bin.js")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")