const regex = /^(?:(?!\.bin\.js$).)+\.js$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!\\.bin\\.js$).)+\\.js$', 'gm')
const str = `I want to match the following:
file1.js
file2.src.js
file3.bin.src.js
But not:
file1.bin.js
file2.src.bin.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}