$re = '/^(?:(?!\.bin\.js$).)+\.js$/m';
$str = 'I want to match the following:
file1.js
file2.src.js
file3.bin.src.js
But not:
file1.bin.js
file2.src.bin.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);