use strict;
my $str = 'I want to match the following:
file1.js
file2.src.js
file3.bin.src.js
But not:
file1.bin.js
file2.src.bin.js';
my $regex = qr/^(?:(?!\.bin\.js$).)+\.js$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}