# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=.*(?:\\/|[[:alnum:]_-])$)(?:\\/Services\\/(?'var'[[:alnum:]_-]+)|(?<!^)\G)\\/(?:(?'params'[[:alnum:]_-]+))?//gm;t' <<< "So
/Services/Test/Ok/Boo/Test
/Services/Test/Ok/Boo/Test/
must be valid
/Services/Test/Ok/Boo/Test+
**/Services/Test/Ok/Boo/Test//**
must be rejecte"