#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=.*(?:\/|[[:alnum:]_-])$)(?:\/Services\/(?'var'[[:alnum:]_-]+)|(?<!^)\G)\/(?:(?'params'[[:alnum:]_-]+))?"
Local $sString = "So" & @CRLF & _
"/Services/Test/Ok/Boo/Test" & @CRLF & _
"/Services/Test/Ok/Boo/Test/" & @CRLF & _
" must be valid" & @CRLF & _
"" & @CRLF & _
"/Services/Test/Ok/Boo/Test+" & @CRLF & _
"**/Services/Test/Ok/Boo/Test//**" & @CRLF & _
"" & @CRLF & _
"must be rejecte"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)