const regex = /(?=.*(?:\/|[[:alnum:]_-])$)(?:\/Services\/(?'var'[[:alnum:]_-]+)|(?<!^)\G)\/(?:(?'params'[[:alnum:]_-]+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*(?:\\\/|[[:alnum:]_-])$)(?:\\\/Services\\\/(?\'var\'[[:alnum:]_-]+)|(?<!^)\\G)\\\/(?:(?\'params\'[[:alnum:]_-]+))?', 'gm')
const str = `So
/Services/Test/Ok/Boo/Test
/Services/Test/Ok/Boo/Test/
must be valid
/Services/Test/Ok/Boo/Test+
**/Services/Test/Ok/Boo/Test//**
must be rejecte`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);