# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=.*(?:\/|[[:alnum:]_-])$)(?:\/Services\/(?'var'[[:alnum:]_-]+)|(?<!^)\G)\/(?:(?'params'[[:alnum:]_-]+))?"
test_str = ("So\n"
"/Services/Test/Ok/Boo/Test\n"
"/Services/Test/Ok/Boo/Test/\n"
" must be valid\n\n"
"/Services/Test/Ok/Boo/Test+\n"
"**/Services/Test/Ok/Boo/Test//**\n\n"
"must be rejecte")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.