import Foundation
let pattern = #"(?=.*(?:\/|[[:alnum:]_-])$)(?:\/Services\/(?'var'[[:alnum:]_-]+)|(?<!^)\G)\/(?:(?'params'[[:alnum:]_-]+))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
So
/Services/Test/Ok/Boo/Test
/Services/Test/Ok/Boo/Test/
must be valid
/Services/Test/Ok/Boo/Test+
**/Services/Test/Ok/Boo/Test//**
must be rejecte
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)