import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*(?:\\/|[[:alnum:]_-])$)(?:\\/Services\\/(?'var'[[:alnum:]_-]+)|(?<!^)\\G)\\/(?:(?'params'[[:alnum:]_-]+))?";
final String string = "So\n"
+ "/Services/Test/Ok/Boo/Test\n"
+ "/Services/Test/Ok/Boo/Test/\n"
+ " must be valid\n\n"
+ "/Services/Test/Ok/Boo/Test+\n"
+ "**/Services/Test/Ok/Boo/Test//**\n\n"
+ "must be rejecte";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}