$re = '/(?=.*(?:\/|[[:alnum:]_-])$)(?:\/Services\/(?\'var\'[[:alnum:]_-]+)|(?<!^)\G)\/(?:(?\'params\'[[:alnum:]_-]+))?/m';
$str = 'So
/Services/Test/Ok/Boo/Test
/Services/Test/Ok/Boo/Test/
must be valid
/Services/Test/Ok/Boo/Test+
**/Services/Test/Ok/Boo/Test//**
must be rejecte';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;