using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*(?:\/|[[:alnum:]_-])$)(?:\/Services\/(?'var'[[:alnum:]_-]+)|(?<!^)\G)\/(?:(?'params'[[:alnum:]_-]+))?";
string substitution = @"";
string input = @"So
/Services/Test/Ok/Boo/Test
/Services/Test/Ok/Boo/Test/
must be valid
/Services/Test/Ok/Boo/Test+
**/Services/Test/Ok/Boo/Test//**
must be rejecte";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}