using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":.+?\.txt(*SKIP)(*FAIL)|\s+";
string input = @"'128.000000 5.000000 2-level SCT3030AL C:\\Users\\Tex\\Desktop\\Test 2 do Project GUI - Opt - Copy\\Vectors\\Ripple = 0.3\\TwoLev9.6kHz_Ripple_0.3.txt 9600.000000'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}