# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r":.+?\.txt(*SKIP)(*FAIL)|\s+"
test_str = "'128.000000 5.000000 2-level SCT3030AL C:\\\\Users\\\\Tex\\\\Desktop\\\\Test 2 do Project GUI - Opt - Copy\\\\Vectors\\\\Ripple = 0.3\\\\TwoLev9.6kHz_Ripple_0.3.txt 9600.000000'"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.