const regex = new RegExp(':.+?\\.txt(*SKIP)(*FAIL)|\\s+', 'gm')
const str = `'128.000000 5.000000 2-level SCT3030AL C:\\\\Users\\\\Tex\\\\Desktop\\\\Test 2 do Project GUI - Opt - Copy\\\\Vectors\\\\Ripple = 0.3\\\\TwoLev9.6kHz_Ripple_0.3.txt 9600.000000'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}