use strict;
my $str = '\'128.000000 5.000000 2-level SCT3030AL C:\\\\Users\\\\Tex\\\\Desktop\\\\Test 2 do Project GUI - Opt - Copy\\\\Vectors\\\\Ripple = 0.3\\\\TwoLev9.6kHz_Ripple_0.3.txt 9600.000000\'';
my $regex = qr~:.+?\.txt(*SKIP)(*FAIL)|\s+~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}