re = /:.+?\.txt(*SKIP)(*FAIL)|\s+/m
str = '\'128.000000 5.000000 2-level SCT3030AL C:\\\\Users\\\\Tex\\\\Desktop\\\\Test 2 do Project GUI - Opt - Copy\\\\Vectors\\\\Ripple = 0.3\\\\TwoLev9.6kHz_Ripple_0.3.txt 9600.000000\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end