// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):.+?\.txt(*SKIP)(*FAIL)|\s+").unwrap();
let string = "'128.000000 5.000000 2-level SCT3030AL C:\\\\Users\\\\Tex\\\\Desktop\\\\Test 2 do Project GUI - Opt - Copy\\\\Vectors\\\\Ripple = 0.3\\\\TwoLev9.6kHz_Ripple_0.3.txt 9600.000000'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}