import Foundation
let pattern = #":.+?\.txt(*SKIP)(*FAIL)|\s+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"'128.000000 5.000000 2-level SCT3030AL C:\\Users\\Tex\\Desktop\\Test 2 do Project GUI - Opt - Copy\\Vectors\\Ripple = 0.3\\TwoLev9.6kHz_Ripple_0.3.txt 9600.000000'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)