#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "GRUB_CMDLINE_LINUX="(?:\s*?([\w=]+)\s*?)+""
Local $sString = "GRUB_CMDLINE_LINUX="cgroup_enable=memory foo=bar swapaccount=1 lala=moo""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")