import Foundation
let pattern = #"GRUB_CMDLINE_LINUX="(?:\s*?([\w=]+)\s*?)+""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"GRUB_CMDLINE_LINUX="cgroup_enable=memory foo=bar swapaccount=1 lala=moo""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}