using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"GRUB_CMDLINE_LINUX=""(?:\s*?([\w=]+)\s*?)+""";
string input = @"GRUB_CMDLINE_LINUX=""cgroup_enable=memory foo=bar swapaccount=1 lala=moo""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}