// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"GRUB_CMDLINE_LINUX="(?:\s*?([\w=]+)\s*?)+""#).unwrap();
let string = "GRUB_CMDLINE_LINUX=\"cgroup_enable=memory foo=bar swapaccount=1 lala=moo\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}