re = /GRUB_CMDLINE_LINUX="(?:\s*?([\w=]+)\s*?)+"/
str = 'GRUB_CMDLINE_LINUX="cgroup_enable=memory foo=bar swapaccount=1 lala=moo"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end