use strict;
my $str = 'GRUB_CMDLINE_LINUX="cgroup_enable=memory foo=bar swapaccount=1 lala=moo"';
my $regex = qr/GRUB_CMDLINE_LINUX="(?:\s*?([\w=]+)\s*?)+"/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}