package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`GRUB_CMDLINE_LINUX="(?:\s*?([\w=]+)\s*?)+"`)
var str = `GRUB_CMDLINE_LINUX="cgroup_enable=memory foo=bar swapaccount=1 lala=moo"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}