# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s(?![\w!.]+"\s)//g;t' <<< "print \"Hello world!\" out.txt
print\"Hello world!\"out.txt"