const regex = /\s(?![\w!.]+"\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(?![\\w!.]+"\\s)', 'g')
const str = `print "Hello world!" out.txt
print"Hello world!"out.txt`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);