using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?![\w!.]+""\s)";
string substitution = @"";
string input = @"print ""Hello world!"" out.txt
print""Hello world!""out.txt";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}