re = /\s(?![\w!.]+"\s)/
str = 'print "Hello world!" out.txt
print"Hello world!"out.txt'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result