#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s(?![\w!.]+"\s)"
Local $sString = "print "Hello world!" out.txt" & @CRLF & _
"print"Hello world!"out.txt"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)