import Foundation
let pattern = #"\s(?![\w!.]+"\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
print "Hello world!" out.txt
print"Hello world!"out.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)