use strict;
my $str = 'print "Hello world!" out.txt
print"Hello world!"out.txt';
my $regex = qr/\s(?![\w!.]+"\s)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";