#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s(?i)case\s{0,1}:\s{0,1}(\d+)"
Local $sString = "This is a string. we want case:12345 and case:5656759 in the title 2." & @CRLF & _
" case:" & @CRLF & _
"CASE : 122235 or CaSe:6666 or case: 12345 or cAsE :13343"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")